Author Topic: Mt. Olympus  (Read 1866 times)

Offline Remick04

  • Moderator
  • ***
  • Posts: 103
    • View Profile
Re: Mt. Olympus
« Reply #15 on: 09-05-2010, 19:05:09 »
Climbing up,unfortunately not
climbing down has been achieved by Clivewil,with some very clever navmeshing and thinking
bots will climb up ladders for a few short seconds,but are hardcoded to jump off

Thanks, that solves the mystery of why no one else had tried it. As Djinn points out bots climbing ladders is only useful for pursuing human players. There usually isn't any place where the use of a ladder is strategically important, so I wasn't going to try anything for now, but this information saves me time in the future.

Before you do, can you stop the bots using one of the spawnpoints at the Monastery? It's in the NE corner, in a room on the second floor accessible only by a ladder.

I got ambushed a few times by a handful of bots that were trapped up there.

Asides from that and the odd case of gridlock at the town gates, the map still works fine for me.
I believe I’ve fix this already, though I’ll check to be sure. I know I set that particular spawnpoint to be ‘for human only’, but I’ll double check.

There shouldn’t be any place on any of the 3 maps where a bot can spawn and not get out onto the battlefield. If it was a spawnpoint that required a navmesh to it, I created a navmesh to it. If it was a spawnpoint where no amount of navmeshing could get the bots out, like the aforementioned room, than I set it to ‘for human only’.

And I did my best with the gridlock issue, bots can get into town from the allied side easily enough. They’re still slow about it and that causes some traffic jam but they are usually able to get out of it.

Offline Drawde

  • Jr. Member
  • **
  • Posts: 160
    • View Profile
Re: Mt. Olympus
« Reply #16 on: 09-05-2010, 20:05:08 »
This is very odd... With the aircraft disabled, the map runs fine - but with any aircraft (I've tried every possible combination) it will inevitably CTD sooner or later (usually sooner). But it looks like I'm the only one experiencing this issue.
I've tried reverting to the 1.2 AI minimod files (after disabling the train) and have tried removing my modified AI strategy files for the map, but still get a CTD every time.
What's even weirder is that none of the aircraft cause any CTD problems on other maps. I tried disabling all the AA guns instead of the aircraft, in case one of these was the actual cause of the crash, but no luck.

Looks like I'll just have to wait and see if the updated Mount Olympus works OK for me!

I also spotted the stuck bots in the Monastery ladder room, and there appears to be another upstairs spawn point, in a room accessed by stairs, where bots get stuck; this may just be a pathfinding/navmesh issue, as they should be able to use the stairs. 

BTW, please don't take all these error reports as criticism - you've done some amazing work in getting these maps working so well in SP. (Many of the "official" maps have just as many bugs and/or CTD issues)

Offline cannonfodder

  • Full Member
  • ***
  • Posts: 1.228
    • View Profile
Re: Mt. Olympus
« Reply #17 on: 10-05-2010, 11:05:20 »
...there appears to be another upstairs spawn point, in a room accessed by stairs, where bots get stuck; this may just be a pathfinding/navmesh issue, as they should be able to use the stairs...
I don't think it's the mesh...I bet if you destroy all the vehicles in the yard, they'll head downstairs and find something else to do.

When bots in FH2 decide to get in a vehicle, they try to walk straight to it, completely ignoring any obstacles in their way. A good example of this is at the German main on Aberdeen, where you'll find a numerous bots trying to walk through, rather than around, trucks to get to a tank. Another great example is the fences on Cobra, at least half of the stuck bots there are trying to get to a tank.

I don't know why only FH bots are like this, but it should be a fixable problem. The only other time I've seen this is when BF2/AIX bots will sometimes get stuck against the tail of a chopper.
« Last Edit: 10-05-2010, 11:05:08 by cannonfodder »

Offline Drawde

  • Jr. Member
  • **
  • Posts: 160
    • View Profile
Re: Mt. Olympus
« Reply #18 on: 10-05-2010, 21:05:57 »
I wonder if the "setUseNoPathfindingToGetToObject 1" line in objects.ai has something to do with this? Though most vehicles, as opposed to static objects, don't have this line (and I assume the default value is 0)