Author Topic: Help Needed With Download 2.56  (Read 340 times)

Offline FHPlayer2525

  • Newbie
  • *
  • Posts: 1
    • View Profile
Help Needed With Download 2.56
« on: 15-05-2020, 18:05:18 »
Okay so I'm updating from 2.55 I open the launcher and says do you want to update. So I start and its seems like its starting to download. But then it stops and says.... An error occurred while updating Forgotten Hope 2. The Underlying connection was Closed. An unexpected error occurred on a send. Received an unexpected EOF or 0 bytes from the transport team. So now i don't know what to do.    Thanks for any help.  Never had any problem updating from the launcher before.
« Last Edit: 15-05-2020, 18:05:14 by FHPlayer2525 »

Offline weegeez

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Help Needed With Download 2.56
« Reply #1 on: 18-05-2020, 19:05:24 »
Hi I have similar problem but not network related.

tLDR: fh2_setup.exe on the 2.56 ISO does not work on 32bit OS. Can a dev provide a 32bit compatible exe?

long version:
I had 2.55 and used the 'update' feature within the launcher, after a long wait, I was able to play 2.56 multiplayer without issue. Very neat feature actually.

Then I had to delete/re-install game for some other reason but this time decided to download the full 2.56 iso instead, as opposed to using 2.55 ISO and using the launcher updater, however, when i mount the 2.56 ISO I get "is not a valid win32 application" which suggests that fh2_setup.exe on the iso is 64bit only. fh2_setup.exe on the 2.55 ISO worked perfectly fine.

My question is, is there a 2.55 > 2.56 patch? (i.e. the file downloaded by launcher seperately available)?
While I could mount 2.55 again and use the the launcher updater a second time, I actually deleted the 2.55 iso to make room on my HDD + The updater is very slow for me (despite my network being fast) thus a 2.55 > 2.56 patch would be ideal here.

I doubt 2.56 will be recompiled because (only) I insist on using XP 32bit, nevertheless as already said, I have played 2.56 online with XP 32bit via 2.55 via launcher updater route without problem in the past.
« Last Edit: 18-05-2020, 20:05:45 by weegeez »

Offline jan_kurator

  • FH-Betatester
  • ***
  • Posts: 2.479
  • Magnificent Mustard
    • View Profile
Re: Help Needed With Download 2.56
« Reply #2 on: 18-05-2020, 20:05:52 »
Try this 2.55 -> 2.56 pre-release file: http://cmpcdn.ovh/fh2/pre-release/Forgotten%20Hope%202%202.56.zip

It's password protected, the password is: 8d3v4AS1Ug

Offline weegeez

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Help Needed With Download 2.56
« Reply #3 on: 18-05-2020, 20:05:20 »
Thanks jan.

Do you have a copy of fh2_setup.exe from 2.55? Maybe I can replace 2.55 fh2_setup.exe onto 2.56 iso (after extraction of ISO to another folder).

I am downloading the pre-release now.

Offline jan_kurator

  • FH-Betatester
  • ***
  • Posts: 2.479
  • Magnificent Mustard
    • View Profile
Re: Help Needed With Download 2.56
« Reply #4 on: 18-05-2020, 23:05:49 »
Do you have a copy of fh2_setup.exe from 2.55? Maybe I can replace 2.55 fh2_setup.exe onto 2.56 iso (after extraction of ISO to another folder).
I doubt there is one. I only ever used FH2 Launcher to update.

Offline weegeez

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Help Needed With Download 2.56
« Reply #5 on: 19-05-2020, 01:05:59 »
Do you have a copy of fh2_setup.exe from 2.55? Maybe I can replace 2.55 fh2_setup.exe onto 2.56 iso (after extraction of ISO to another folder).
I doubt there is one. I only ever used FH2 Launcher to update.

Nevermind I've since downloaded 2.55 ISO again and have the (working) fh2_setup.exe.
I copied it and  overwrite fh2_setup.exe on 2.56 ISO with 2.55 version but this did not fix 2.56 standalone install. Therefore, currently the only way for 32bit users to install 2.56 is to download 2.55 and update via launcher updater. (but 2.55 links are hard to find I had to do extensive google search to find it again).

So can any devs confirm whether 2.56 "full" .iso will be revised?
This problem surely will limit the number of new players because 32bit is still relatively popular today. I think its a major flaw of 2.56...

Edit I installed 2.55 and then the pre-release in that order and it now works. 2.56 needs revision though.
« Last Edit: 19-05-2020, 02:05:24 by weegeez »

Offline radiosmersh

  • FH-Betatester
  • ***
  • Posts: 227
    • View Profile
Re: Help Needed With Download 2.56
« Reply #6 on: 19-05-2020, 17:05:09 »
This problem surely will limit the number of new players because 32bit is still relatively popular today. I think its a major flaw of 2.56...
Do you use XP by any chance? I discovered the cause of the problem, it was the newest Inno Setup version I used to compile the standalone installer (6.x), because as it turned out, XP support was deprecated with its release. I did a fresh Windows reinstall some time ago and had to install Inno from scratch as well, but didn't pay attention to the deprecation notice. Now I'll have to recompile the installer using old version, and I bring apologies on my end for that.
« Last Edit: 19-05-2020, 17:05:39 by radiosmersh »