Author Topic: Freesync and still screentearing  (Read 101 times)

Offline United_Stealth

  • Newbie
  • *
  • Posts: 13
    • View Profile
Freesync and still screentearing
« on: 21-05-2019, 22:05:48 »
I got a 75hz monitor with freesync support.
It's enabled and all that, FH2 runs a smooth 75hz, limited via launcher.
However I still get screentearing, a lot.
I even forced freesync and vsync via AMD Settings, but it doesn't make much of a difference, if at all.

Does anyone know a way I can get it to work?

Offline Stubbfan

  • Developer
  • ******
  • Posts: 500
    • View Profile
Re: Freesync and still screentearing
« Reply #1 on: 21-05-2019, 23:05:26 »
What happens if you put the launcher to a higher fps limit?

Offline Leopardi

  • Jr. Member
  • **
  • Posts: 738
  • [11PzG] member
    • View Profile
Re: Freesync and still screentearing
« Reply #2 on: 22-05-2019, 12:05:59 »
You need to cap 3 FPS below refresh rate (in your case 72), and enable VSYNC from GPU control panel. At least with gsync it goes like that.

Offline United_Stealth

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Freesync and still screentearing
« Reply #3 on: 22-05-2019, 13:05:44 »
Thanks guys, I've been playing around with the launcher settings. Turned it up to 100 (but still limited by amd settings) and down to 60, but that didn't work.
Now I've turned the launcher limiter off and set the fps limit van AMD Settings to 74 fps.
That seems to do the trick for now.
Thanks for the advice  :)