Author Topic: [Fix] Broken Wounded Shaders on Nvidia with AA enabled  (Read 10068 times)

Offline Ionizer

  • Full Member
  • ***
  • Posts: 1.524
  • Carrier of Squirrel Flu
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #15 on: 14-09-2009, 17:09:41 »
So it looks like a pre 19x.xx driver is needed to make it work as intended. I'm still at 186.18WHQL right now.

If you're going to do that, might as well just use an older driver that doesn't break the whole damn thing in the first place....
 

Offline Apo-TTCC

  • Jr. Member
  • **
  • Posts: 53
  • FH2 Betatester
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #16 on: 14-09-2009, 19:09:23 »
So it looks like a pre 19x.xx driver is needed to make it work as intended. I'm still at 186.18WHQL right now.

If you're going to do that, might as well just use an older driver that doesn't break the whole damn thing in the first place....
Well the last known working driver, 178.83, was released mid August 2008. So it is a bit out of date for my card, which came out January 2009 and also does not contain several fixes i need for some of my newer games. 186.18, the one i'm using now, is from late June 2009. So we are just waiting for an updated and working with the latest Nvidia drivers nHancer version right now.  ;)

This workaround is not a final, 100% working fix, due to the known circumstances but it is at least one way to have the mod to perform the way it is intended to with having AA running at the same time, while using an almost up to date driver.

I was just informed that nHancer Beta 2 and the 190.62 drivers work well together and that the fix is working with those two combined. Added the infos to the first post.


« Last Edit: 14-09-2009, 22:09:54 by Apo-TTCC »
ß

Offline MK

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #17 on: 15-09-2009, 00:09:44 »
Quote
I was just informed that nHancer Beta 2 and the 190.62 drivers work well together and that the fix is working with those two combined

Sorry but doesn't work,tested witch 190.62 :-\

Offline Apo-TTCC

  • Jr. Member
  • **
  • Posts: 53
  • FH2 Betatester
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #18 on: 15-09-2009, 01:09:04 »
Quote
I was just informed that nHancer Beta 2 and the 190.62 drivers work well together and that the fix is working with those two combined

Sorry but doesn't work,tested witch 190.62 :-\
I'll tell Lord Helmchen about, he was the one who tried it and it worked for him. Maybe he can reply with some helpful additional infos what exactly he did.

He mentioned that he did delete the shader cache too, did you try that yet?

« Last Edit: 15-09-2009, 01:09:00 by Apo-TTCC »
ß

Offline MK

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #19 on: 15-09-2009, 02:09:50 »
Yes i deleted all shaders,what card Helmchen have?

Offline hslan.Lord Helmchen

  • Jr. Member
  • **
  • Posts: 61
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #20 on: 15-09-2009, 15:09:36 »
Ok here we go:

I did all the steps apo explained in order. First installed nhancer (the recent beta!), secondly applied his described changes to the bf2 profile (and only that one), then deleted the cache folders, set the ingame aa to "off" (!) and ultimately ran the game.
Everything works like a charm now. The anisotropic filtering gives very nice additional eyecandies to the game ;)
I own a geforce 8800 gt with 190.62 on win xp sp 3.

Offline MK

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #21 on: 15-09-2009, 16:09:44 »
I did all the steps but I don't see AA in game :( omfg

8800gt,190.62,xp sp3

Offline hslan.Lord Helmchen

  • Jr. Member
  • **
  • Posts: 61
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #22 on: 16-09-2009, 18:09:34 »
YOu have to activate the 8x aa not the 8xQ aa!

Offline MK

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #23 on: 16-09-2009, 20:09:57 »
Yes i did it, AAx8 and AFx16 too and many other things  ??? i did exactly like in first post here

Offline hslan.Lord Helmchen

  • Jr. Member
  • **
  • Posts: 61
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #24 on: 17-09-2009, 00:09:04 »
All I then can suggest is to reinstall the driver and reapply the nhancer once more. Be sure to disable the ingame aa before that.

Offline SchwererGustav

  • I belong to Naughty Club
  • **
  • Posts: 77
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #25 on: 20-09-2009, 16:09:03 »
I have it working this way don't know atm.  what version of Driver i have...

anyway @MK:  maybe a silly question but do you have activate the BF2 profil in the enhancer?

I forgot it at the first time  :P

Offline MK

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #26 on: 20-09-2009, 19:09:56 »
Activate?how?all changes are applied automatically

is any option to activate?how look active and inactive profile?

Offline SchwererGustav

  • I belong to Naughty Club
  • **
  • Posts: 77
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #27 on: 20-09-2009, 19:09:09 »
Activate?how?all changes are applied automatically

is any option to activate?how look active and inactive profile?


right click enhancer ->activate Profil (the first) -> Battlefield 2


not sure about "activate Profil" i have a german version

Offline hslan.Lord Helmchen

  • Jr. Member
  • **
  • Posts: 61
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #28 on: 26-09-2009, 14:09:09 »
Ok now I managed somehow to screw up my stuff here, too. The problem was solved all the time until yesterday were suddenly everything was messed up again (no AA).

BUT

after a lot of trying I found a way to make it work again with 190.62! I followed this link:http://forum.nhancer.com/showthread.php?t=1086&page=9 and found following solution:

"Uninstall nHancer v2.5.3 beta 2
Uninstall v190.62WHQL
Reboot
Delete all remaining nvapps.xml and extendedProfiles.xml files (use search on c:\) <-- important!
Reinstall 190.62 WHQL
Go into CP and in 3D options and in "AA mode" for global, set AA mode on "Override all applications parameters"
Reinstall nHancer v2.5.3 beta 2
Set AA in all your games
Go back into CP and restore original settings of 3D options for global"

The order is very important!! So follow it wisely.

Offline hslan.Lord Helmchen

  • Jr. Member
  • **
  • Posts: 61
    • View Profile
Re: [Fix] Broken Wounded Shaders on Nvidia with AA enabled
« Reply #29 on: 11-10-2009, 20:10:21 »
theres a new version of nhancer out there: http://nhancer.com/. It seems as if it clears all probs without walkaround. Made it successfully working with 191.07